Multiple Jenkins plugins received updates today that fix several security vulnerabilities, including multiple high severity ones.

We strongly recommend updating the following plugins as soon as possible:

Less severe security updates have been released for these plugins:

Additionally, the OWASP Dependency-Check Plugin recently also received a security update.

For an overview of what was fixed, see the security advisory.

Subscribe to the jenkinsci-advisories mailing list to receive important future notifications related to Jenkins security.